aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGeorge Kadianakis <desnacked@riseup.net>2019-02-25 15:29:41 +0200
committerNick Mathewson <nickm@torproject.org>2019-03-13 10:36:26 -0400
commit8b64ff7a3f2d9eb0837248a6c9b0e8b438374369 (patch)
tree07e51d93495c3adaab516a137604d9332d624e02 /configure.ac
parenta71999462b8d185c70169c4cba3efde6e55393ce (diff)
downloadtor-8b64ff7a3f2d9eb0837248a6c9b0e8b438374369.tar.gz
tor-8b64ff7a3f2d9eb0837248a6c9b0e8b438374369.zip
Silence unneeded clang warns that triggered in prob distr tests.
See https://trac.torproject.org/projects/tor/ticket/29528#comment:3 and https://bugs.llvm.org/show_bug.cgi?id=19535
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 75bb0c7bd9..8f05637538 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1196,6 +1196,11 @@ if test "$fragile_hardening" = "yes"; then
AC_MSG_ERROR([The compiler supports -fsanitize=undefined, but for some reason I was not able to link when using it. Are you missing run-time support? With GCC you need libasan.*, and with Clang you need libclang_rt.ubsan*])
fi
+ TOR_TRY_COMPILE_WITH_CFLAGS([-fno-sanitize=float-divide-by-zero], also_link, CFLAGS_UBSAN="-fno-sanitize=float-divide-by-zero", true)
+ if test "$tor_cv_cflags__fno_sanitize_float_divide_by_zero" = "yes" && test "$tor_can_link__fno_sanitize_float_divide_by_zero" != "yes"; then
+ AC_MSG_ERROR([The compiler supports -fno-sanitize=float-divide-by-zero, but for some reason I was not able to link when using it. Are you missing run-time support? With GCC you need libasan.*, and with Clang you need libclang_rt.ubsan*])
+ fi
+
TOR_CHECK_CFLAGS([-fno-omit-frame-pointer])
fi