aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2016-02-05 14:40:07 +0100
committerSebastian Hahn <sebastian@torproject.org>2016-02-05 14:40:07 +0100
commit55d6fd27cbe6f058a1f444f47f05c7b64891655e (patch)
tree9844f3a814ff8b9055015e2ba63635964e979313 /configure.ac
parent5d63cbf7f94d7747c00f6bf30a4094d13dc92332 (diff)
downloadtor-55d6fd27cbe6f058a1f444f47f05c7b64891655e.tar.gz
tor-55d6fd27cbe6f058a1f444f47f05c7b64891655e.zip
Fix the --disable-asserts-in-tests configure option
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d92f1e66a2..25d63c9ce6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,8 +46,14 @@ AC_ARG_ENABLE(asserts-in-tests,
AC_ARG_ENABLE(system-torrc,
AS_HELP_STRING(--disable-system-torrc, [don't look for a system-wide torrc file]))
+if test x$enable_coverage != xyes -a x$enable_asserts_in_tests = xno ; then
+ AC_MSG_ERROR([Can't disable assertions outside of coverage build])
+fi
+
+
AM_CONDITIONAL(UNITTESTS_ENABLED, test x$enable_unittests != xno)
AM_CONDITIONAL(COVERAGE_ENABLED, test x$enable_coverage = xyes)
+AM_CONDITIONAL(DISABLE_ASSERTS_IN_UNIT_TESTS, test x$enable_asserts_in_tests = xno)
if test "$enable_static_tor" = "yes"; then
enable_static_libevent="yes";