aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-07-26 12:32:34 -0500
committerTaylor Yu <catalyst@torproject.org>2018-07-26 12:32:34 -0500
commita8bdb851eb23b6067e24ad955bb8f499b8348b95 (patch)
treef89a10d107486332c54dfe2a08376e7f93c24da9 /configure.ac
parentbe3a962ca7c6fc5fd72dfd9bb1def24efa4cdf2a (diff)
downloadtor-a8bdb851eb23b6067e24ad955bb8f499b8348b95.tar.gz
tor-a8bdb851eb23b6067e24ad955bb8f499b8348b95.zip
Don't disable an unsupported compiler warning
Conditionalize the pragma that temporarily disables -Wunused-const-variable. Some versions of gcc don't support it. We need to do this because of an apparent bug in some libzstd headers. Fixes bug 26785; bugfix on 0.3.2.11.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c883279a60..37a78b779d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2143,6 +2143,9 @@ dnl -Wthread-safety-precise
if test "$tor_cv_cflags__Woverlength_strings" = "yes"; then
AC_DEFINE([HAVE_CFLAG_WOVERLENGTH_STRINGS], 1, [True if we have -Woverlength-strings])
fi
+ if test "$tor_cv_cflags__warn_unused_const_variable_2" = "yes"; then
+ AC_DEFINE([HAVE_CFLAG_WUNUSED_CONST_VARIABLE], 1, [True if we have -Wunused-const-variable])
+ fi
if test "x$enable_fatal_warnings" = "xyes"; then
# I'd like to use TOR_CHECK_CFLAGS here, but I can't, since the