aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-03 07:33:39 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-03 07:33:39 -0400
commit42c6ebda1626371cc6b0fff0cc0710b841936bef (patch)
treef36277e4cfb6c2042c56e17e4e3437cead70d2d7 /configure.ac
parent6443812e343635d0db6ea1aac58b817732b7f29a (diff)
parent16bdbddc2cab90e360002b3440a4ed634e3c87f1 (diff)
downloadtor-42c6ebda1626371cc6b0fff0cc0710b841936bef.tar.gz
tor-42c6ebda1626371cc6b0fff0cc0710b841936bef.zip
Merge branch 'fix_nonstandard_malloc_029' into maint-0.2.9
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 279660d9b2..d700329925 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1438,6 +1438,10 @@ fi
if test "$using_custom_malloc" = "no"; then
AC_CHECK_FUNCS(mallinfo)
fi
+if test "$using_custom_malloc" = "yes"; then
+ # Tell the C compiler not to use the system allocator functions.
+ TOR_CHECK_CFLAGS([-fno-builtin-malloc -fno-builtin-realloc -fno-builtin-calloc -fno-builtin-free])
+fi
# By default, we're going to assume we don't have mlockall()
# bionic and other platforms have various broken mlockall subsystems.