aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-01-09 10:44:55 -0500
committerNick Mathewson <nickm@torproject.org>2017-01-30 08:37:25 -0500
commit1b244a64e403f9b6bd452d1f2e9c961a1f91e2d7 (patch)
treea28ab8b8ecb8e509a1b85be48bba4543a8a1344b /configure.ac
parent024fa9d4d76d21d1a51b0a362552bcbff4159b3a (diff)
downloadtor-1b244a64e403f9b6bd452d1f2e9c961a1f91e2d7.tar.gz
tor-1b244a64e403f9b6bd452d1f2e9c961a1f91e2d7.zip
libfuzzer tweaks per recommendations
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 784b3cde14..aff41ae60a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -50,7 +50,9 @@ AC_ARG_ENABLE(asserts-in-tests,
AC_ARG_ENABLE(system-torrc,
AS_HELP_STRING(--disable-system-torrc, [don't look for a system-wide torrc file]))
AC_ARG_ENABLE(libfuzzer,
- AS_HELP_STRING(--libfuzzer, [build extra fuzzers based on 'libfuzzer']))
+ AS_HELP_STRING(--enable-libfuzzer, [build extra fuzzers based on 'libfuzzer']))
+AC_ARG_ENABLE(oss-fuzz,
+ AS_HELP_STRING(--enable-oss-fuzz, [build extra fuzzers based on 'oss-fuzz' environment]))
if test "x$enable_coverage" != "xyes" -a "x$enable_asserts_in_tests" = "xno" ; then
AC_MSG_ERROR([Can't disable assertions outside of coverage build])
@@ -60,6 +62,7 @@ AM_CONDITIONAL(UNITTESTS_ENABLED, test "x$enable_unittests" != "xno")
AM_CONDITIONAL(COVERAGE_ENABLED, test "x$enable_coverage" = "xyes")
AM_CONDITIONAL(DISABLE_ASSERTS_IN_UNIT_TESTS, test "x$enable_asserts_in_tests" = "xno")
AM_CONDITIONAL(LIBFUZZER_ENABLED, test "x$enable_libfuzzer" = "xyes")
+AM_CONDITIONAL(OSS_FUZZ_ENABLED, test "x$enable_oss_fuzz" = "xyes")
if test "$enable_static_tor" = "yes"; then
enable_static_libevent="yes";