aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2013-09-22 21:30:46 -0400
committerNick Mathewson <nickm@torproject.org>2015-01-14 10:41:53 -0500
commitc2f0d52b7fb937f3f66ef8b2b74b0fdf239b0e9b (patch)
treec0deccd74112c5d135d018099f616842431e81ee /configure.ac
parent518b0b3c5fefba2458181c7f733bc684e5466cf9 (diff)
downloadtor-c2f0d52b7fb937f3f66ef8b2b74b0fdf239b0e9b.tar.gz
tor-c2f0d52b7fb937f3f66ef8b2b74b0fdf239b0e9b.zip
Split threading-related code out of compat.c
Also, re-enable the #if'd out condition-variable code. Work queues are going to make us hack on all of this stuff a bit more closely, so it might not be a terrible idea to make it easier to hack.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c254725c60..65b3ff245c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -393,6 +393,10 @@ fi
AC_SEARCH_LIBS(pthread_create, [pthread])
AC_SEARCH_LIBS(pthread_detach, [pthread])
+AM_CONDITIONAL(THREADS_WIN32, test "$enable_threads" = "yes" && test "$bwin32" = "true")
+AM_CONDITIONAL(THREADS_PTHREADS, test "$enable_threads" = "yes" && test "$bwin32" = "false")
+AM_CONDITIONAL(THREADS_NONE, test "$enable_threads" != "yes")
+
dnl -------------------------------------------------------------------
dnl Check for functions before libevent, since libevent-1.2 apparently
dnl exports strlcpy without defining it in a header.