aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-01-06 17:07:01 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-06 17:07:40 -0500
commit6bb31cba1286e843ac7d32a24a9424587bc29623 (patch)
tree6c2172979323366f81f3d86bef3c0ead4634f293 /configure.ac
parent14dedff0abd8b6b9c1c2766fe0ce5844c77d58ac (diff)
downloadtor-6bb31cba1286e843ac7d32a24a9424587bc29623.tar.gz
tor-6bb31cba1286e843ac7d32a24a9424587bc29623.zip
New option "--disable-system-torrc" to not read torrc from etc
Implements 13037.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c92a6c409..920a12f4bd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,8 @@ AC_ARG_ENABLE(unittests,
AS_HELP_STRING(--disable-unittests, [Don't build unit tests for Tor. Risky!]))
AC_ARG_ENABLE(coverage,
AS_HELP_STRING(--enable-coverage, [Enable coverage support in the unit-test build]))
+AC_ARG_ENABLE(system-torrc,
+ AS_HELP_STRING(--disable-system-torrc, [Don't look for a system-wide torrc file]))
AM_CONDITIONAL(UNITTESTS_ENABLED, test x$enable_unittests != xno)
AM_CONDITIONAL(COVERAGE_ENABLED, test x$enable_coverage = xyes)
@@ -56,6 +58,11 @@ if test "$enable_static_tor" = "yes"; then
CFLAGS="$CFLAGS -static"
fi
+if test "$enable_system_torrc" = "no"; then
+ AC_DEFINE(DISABLE_SYSTEM_TORRC, 1,
+ [Defined if we're not going to look for a torrc in SYSCONF])
+fi
+
if test x$enable_buf_freelists = xyes; then
AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
[Defined if we try to use freelists for buffer RAM chunks])