aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-01-18 16:07:08 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-18 16:07:08 -0500
commit63765399eb844adfa877a288e655eb281ac8c988 (patch)
treec713bc1e54dc4e69282db2c9b221c26d4e4bb479 /configure.ac
parent5aa55a1369dbcb849f1290291c48054f25cdd623 (diff)
parentffa4ed8d3dea0ffdde2369b1feb24bc3a9b6c101 (diff)
downloadtor-63765399eb844adfa877a288e655eb281ac8c988.tar.gz
tor-63765399eb844adfa877a288e655eb281ac8c988.zip
Merge remote-tracking branch 'public/ticket13037'
Conflicts: src/or/config.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c254725c60..efeea0658e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,8 @@ AC_ARG_ENABLE(unittests,
AS_HELP_STRING(--disable-unittests, [Don't build unit tests for Tor. Risky!]))
AC_ARG_ENABLE(coverage,
AS_HELP_STRING(--enable-coverage, [Enable coverage support in the unit-test build]))
+AC_ARG_ENABLE(system-torrc,
+ AS_HELP_STRING(--disable-system-torrc, [Don't look for a system-wide torrc file]))
AM_CONDITIONAL(UNITTESTS_ENABLED, test x$enable_unittests != xno)
AM_CONDITIONAL(COVERAGE_ENABLED, test x$enable_coverage = xyes)
@@ -56,6 +58,11 @@ if test "$enable_static_tor" = "yes"; then
CFLAGS="$CFLAGS -static"
fi
+if test "$enable_system_torrc" = "no"; then
+ AC_DEFINE(DISABLE_SYSTEM_TORRC, 1,
+ [Defined if we're not going to look for a torrc in SYSCONF])
+fi
+
if test x$enable_buf_freelists = xyes; then
AC_DEFINE(ENABLE_BUF_FREELISTS, 1,
[Defined if we try to use freelists for buffer RAM chunks])