summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-22 10:30:45 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-22 10:31:51 -0400
commit97b15a1d7c51764888d2172711e3f3a71fb01916 (patch)
tree2d7be35820f099e0d7da91f0e4eb49baa99476e4 /Makefile.am
parent2cf033f238c111bef62552da16117568435d3a18 (diff)
downloadtor-97b15a1d7c51764888d2172711e3f3a71fb01916.tar.gz
tor-97b15a1d7c51764888d2172711e3f3a71fb01916.zip
Extract the locking and logging code
The locking code gets its own module, since it's more fundamental than the higher-level locking code. Extracting the logging code was the whole point here. :)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 172ab36f6a..b6200c6a27 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,6 +40,8 @@ endif
# "Common" libraries used to link tor's utility code.
TOR_UTIL_LIBS = \
src/common/libor.a \
+ src/lib/libtor-log.a \
+ src/lib/libtor-lock.a \
src/lib/libtor-container.a \
src/lib/libtor-string.a \
src/lib/libtor-malloc.a \
@@ -52,6 +54,8 @@ TOR_UTIL_LIBS = \
# and tests)
TOR_UTIL_TESTING_LIBS = \
src/common/libor-testing.a \
+ src/lib/libtor-log-testing.a \
+ src/lib/libtor-lock-testing.a \
src/lib/libtor-container-testing.a \
src/lib/libtor-string-testing.a \
src/lib/libtor-malloc-testing.a \