summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-21 10:34:29 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-21 10:35:30 -0400
commitb2346b12019c45288bbae3bd009fe0bafe80ff58 (patch)
treeeafe8c2bb25c7afe03207d21d35da3f830b83dc8 /Makefile.am
parentda728e36f45799077a8d24a0be95ab5db78593f4 (diff)
downloadtor-b2346b12019c45288bbae3bd009fe0bafe80ff58.tar.gz
tor-b2346b12019c45288bbae3bd009fe0bafe80ff58.zip
Refactor makefiles to keep list of internal libraries in one place.
This change makes it possible for us to change the list of libraries more easily, without changing every single linker line.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c10c7f952..579b9a089c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,6 +37,53 @@ else
rust_ldadd=
endif
+# "Common" libraries used to link tor's utility code.
+TOR_UTIL_LIBS = \
+ src/common/libor.a \
+ src/common/libor-ctime.a
+
+# Variants of the above for linking the testing variant of tor (for coverage
+# and tests)
+TOR_UTIL_TESTING_LIBS = \
+ src/common/libor-testing.a \
+ src/common/libor-ctime-testing.a
+
+# Internal crypto libraries used in Tor
+TOR_CRYPTO_LIBS = \
+ src/common/libor-crypto.a \
+ $(LIBKECCAK_TINY) \
+ $(LIBDONNA)
+
+# Variants of the above for linking the testing variant of tor (for coverage
+# and tests)
+TOR_CRYPTO_TESTING_LIBS = \
+ src/common/libor-crypto-testing.a \
+ $(LIBKECCAK_TINY) \
+ $(LIBDONNA)
+
+# All static libraries used to link tor.
+TOR_INTERNAL_LIBS = \
+ src/or/libtor.a \
+ $(TOR_CRYPTO_LIBS) \
+ $(TOR_UTIL_LIBS) \
+ src/common/libor-event.a \
+ src/trunnel/libor-trunnel.a \
+ src/trace/libor-trace.a
+
+# Variants of the above for linking the testing variant of tor (for coverage
+# and tests)
+TOR_INTERNAL_TESTING_LIBS = \
+ src/or/libtor-testing.a \
+ $(TOR_CRYPTO_TESTING_LIBS) \
+ $(TOR_UTIL_TESTING_LIBS) \
+ $(LIBKECCAK_TINY) \
+ $(LIBDONNA) \
+ src/common/libor-event-testing.a \
+ src/trunnel/libor-trunnel-testing.a \
+ src/trace/libor-trace.a
+
+# All libraries used to link tor-cov
+
include src/include.am
include doc/include.am
include contrib/include.am