summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-04-26 16:07:56 -0500
committerTaylor Yu <catalyst@torproject.org>2018-04-26 16:07:56 -0500
commitf0dc6c8e2a68764b73ea4b3fdb50f74b070c183b (patch)
treefdfd1e9def399482babbd2f802ae9761af9da2ac /Makefile.am
parent58f54a3588cf722a31b10fa0450225f7685c8629 (diff)
parent2edc9cd48457169409841c794832172bc959e63a (diff)
downloadtor-f0dc6c8e2a68764b73ea4b3fdb50f74b070c183b.tar.gz
tor-f0dc6c8e2a68764b73ea4b3fdb50f74b070c183b.zip
Merge branch 'bug25936-032' into bug25936-033
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 04ca88a236..08cb8e3e7e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -254,3 +254,11 @@ if USE_RUST
distclean-local: distclean-rust
endif
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi