summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-01-11 20:17:04 -0500
committerNick Mathewson <nickm@torproject.org>2019-03-25 16:35:33 -0400
commite4d3098d4d23686320013b80b6305fbd52863f76 (patch)
tree96c23b73d84025ec42e676b4087c6b7aaa5dd63e /Makefile.am
parenta62ac1719887f0756ceb516ce3b12cd2aee18191 (diff)
downloadtor-e4d3098d4d23686320013b80b6305fbd52863f76.tar.gz
tor-e4d3098d4d23686320013b80b6305fbd52863f76.zip
Low-level dispatch module for publish-subscribe mechanism
This module implements a way to send messages from one module to another, with associated data types. It does not yet do anything to ensure that messages are correct, that types match, or that other forms of consistency are preserved.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a5086b3035..36d9725f38 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,7 @@ TOR_UTIL_LIBS = \
src/lib/libtor-geoip.a \
src/lib/libtor-process.a \
src/lib/libtor-buf.a \
+ src/lib/libtor-dispatch.a \
src/lib/libtor-time.a \
src/lib/libtor-fs.a \
src/lib/libtor-encoding.a \
@@ -72,6 +73,7 @@ TOR_UTIL_TESTING_LIBS = \
src/lib/libtor-geoip-testing.a \
src/lib/libtor-process-testing.a \
src/lib/libtor-buf-testing.a \
+ src/lib/libtor-dispatch-testing.a \
src/lib/libtor-time-testing.a \
src/lib/libtor-fs-testing.a \
src/lib/libtor-encoding-testing.a \