summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2021-01-21 16:07:16 -0500
committerDavid Goulet <dgoulet@torproject.org>2021-01-21 16:07:16 -0500
commite06a0e904cdc80566147a3d718366abe7dd8929d (patch)
treebe780c66e262248ec22474037bcef1ad047e4b67 /Makefile.am
parentc54f4b81da5635b282fc45c6301c490663113434 (diff)
parent2a3cf374508f48adc45b6cc6825dd341a71f5a0b (diff)
downloadtor-e06a0e904cdc80566147a3d718366abe7dd8929d.tar.gz
tor-e06a0e904cdc80566147a3d718366abe7dd8929d.zip
Merge branch 'maint-0.4.4' into maint-0.4.5
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6e8ba37e3a..3056b08446 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -725,3 +725,17 @@ show-libs:
show-testing-libs:
@echo src/test/libtor-testing.a
+
+# Note here that we hardcode this -j2 because if the user would pass too many
+# cores, bear actually chockes and dies :S. For this to work, a make clean
+# needs to be done else bear will miss some compile flags.
+lsp:
+ @if test -x "`which bear 2>&1;true`"; then \
+ echo "Generating LSP compile_commands.json. Might take few minutes..."; \
+ $(MAKE) clean 2>&1 >/dev/null; \
+ bear >/dev/null 2>&1 -- $(MAKE) -j2 2>&1 >/dev/null; \
+ echo "Generating .ccls file..."; \
+ ./scripts/maint/gen_ccls_file.sh \
+ else \
+ echo "No bear command found. On debian, apt install bear"; \
+ fi