summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-11-24 20:03:48 -0500
committerNick Mathewson <nickm@torproject.org>2018-11-24 20:44:37 -0500
commitb16d6453adde2b13d2aa95a74ec3c09a259f185f (patch)
tree6a642bf80eb9bce36e55ee7a2c7e022a292be7be /Makefile.am
parent3741f9e524a2d3bd7239ca865d6169fd1e3dddb5 (diff)
downloadtor-b16d6453adde2b13d2aa95a74ec3c09a259f185f.tar.gz
tor-b16d6453adde2b13d2aa95a74ec3c09a259f185f.zip
Rewrite updateVersions script in Python, add datestamp functionality.
This updateVersions.pl script was one of the only essential perl scripts left in out maint system, and was the only one that used autoconf to fill in the script. This script adds a feature to define an APPROX_RELEASE_DATE macro that is updated when the version changes. We'll use this to implement prop297, so that we have an accurate view of when a release date happens.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 803e9d00df..cbe94ad937 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -416,7 +416,7 @@ endif
.PHONY: update-versions
update-versions:
- $(PERL) $(top_builddir)/scripts/maint/updateVersions.pl
+ abs_top_srcdir="$(abs_top_srcdir)" $(PYTHON) $(top_srcdir)/scripts/maint/update_versions.py
.PHONY: callgraph
callgraph: