summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Goulet <dgoulet@torproject.org>2021-01-21 16:06:54 -0500
committerDavid Goulet <dgoulet@torproject.org>2021-01-21 16:06:54 -0500
commit2a3cf374508f48adc45b6cc6825dd341a71f5a0b (patch)
tree1d2ff7d05cedc01a3af06fad8dd23d8f6495905c /Makefile.am
parentd54cd853ad22ae02b3b41a10b3f166669455f8ae (diff)
parentc09f8da8a98d035082b207ebdaf1e6fe3110c8b7 (diff)
downloadtor-2a3cf374508f48adc45b6cc6825dd341a71f5a0b.tar.gz
tor-2a3cf374508f48adc45b6cc6825dd341a71f5a0b.zip
Merge branch 'maint-0.4.3' into maint-0.4.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 49d5637428..a723c167ef 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -706,3 +706,17 @@ show-libs:
show-testing-libs:
@echo $(TOR_INTERNAL_TESTING_LIBS)
+
+# Note here that we hardcode this -j2 because if the user would pass too many
+# cores, bear actually chockes and dies :S. For this to work, a make clean
+# needs to be done else bear will miss some compile flags.
+lsp:
+ @if test -x "`which bear 2>&1;true`"; then \
+ echo "Generating LSP compile_commands.json. Might take few minutes..."; \
+ $(MAKE) clean 2>&1 >/dev/null; \
+ bear >/dev/null 2>&1 -- $(MAKE) -j2 2>&1 >/dev/null; \
+ echo "Generating .ccls file..."; \
+ ./scripts/maint/gen_ccls_file.sh \
+ else \
+ echo "No bear command found. On debian, apt install bear"; \
+ fi