summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorrl1987 <rl1987@sdf.lonestar.org>2018-12-15 10:47:30 +0200
committerNick Mathewson <nickm@torproject.org>2019-01-15 08:08:29 -0500
commit136e6e7cebbba00e7bd33cb1bc1e660e01e966fd (patch)
treee8f5ee6b60587945c77ce1ae4304ef72a50b690f /Makefile.am
parentf8dac5c900856494867996f60da848b0111aad35 (diff)
downloadtor-136e6e7cebbba00e7bd33cb1bc1e660e01e966fd.tar.gz
tor-136e6e7cebbba00e7bd33cb1bc1e660e01e966fd.zip
Run shellcheck for stuff in scripts/ as part of 'make check'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a945130213..272724340b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -215,7 +215,16 @@ doxygen:
test: all
$(top_builddir)/src/test/test
-check-local: check-spaces check-changes check-includes
+shellcheck:
+ # Only use shellcheck if it is present
+ if command -v shellcheck; then \
+ find $(top_srcdir)/scripts/ -name "*.sh" -exec shellcheck {} +; \
+ if [ -d "$(top_srcdir)/scripts/test" ]; then \
+ shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_builddir)/scripts/test/coverage; \
+ fi; \
+ fi
+
+check-local: check-spaces check-changes check-includes shellcheck
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \