summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
commita28c14aad547fd1b254bdbf2acc1ff2b67551a96 (patch)
tree6698d66db0917244369e22ce699e42ac76290179 /Makefile.am
parent64c3c6a790278f82b0d3fef7fa1ac675c9733457 (diff)
parentb40f9967fa31faa1dcf1a977989e235fbe836015 (diff)
downloadtor-a28c14aad547fd1b254bdbf2acc1ff2b67551a96.tar.gz
tor-a28c14aad547fd1b254bdbf2acc1ff2b67551a96.zip
Merge branch 'maint-0.3.2' into maint-0.3.3
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 08cb8e3e7e..dcb445c970 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -125,6 +125,7 @@ test-network: need-chutney-path $(TESTING_TOR_BINARY) src/tools/tor-gencert
# because they're incompatible
test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/tor-gencert
mkdir -p $(TEST_NETWORK_ALL_LOG_DIR)
+ rm -f $(TEST_NETWORK_ALL_LOG_DIR)/*.log $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
@flavors="$(TEST_CHUTNEY_FLAVORS)"; \
if ping6 -q -c 1 -o ::1 >/dev/null 2>&1 || ping6 -q -c 1 -W 1 ::1 >/dev/null 2>&1 || ping -6 -c 1 -W 1 ::1 >/dev/null 2>&1; then \
echo "ping6 ::1 or ping ::1 succeeded, running IPv6 flavors: $(TEST_CHUTNEY_FLAVORS_IPV6)."; \
@@ -148,7 +149,7 @@ test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/
$(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_WARNING_FLAGS); \
done; \
echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
- ! grep -q FAIL test_network_log/*.trs
+ ! grep -q FAIL $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
need-stem-path:
@if test ! -d "$$STEM_SOURCE_DIR"; then \