summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Kadianakis <desnacked@riseup.net>2019-04-05 14:55:09 +0300
committerGeorge Kadianakis <desnacked@riseup.net>2019-04-05 14:55:09 +0300
commit7fe169a5000d56f081191f4ca073453f2dc3610b (patch)
treee8ad8fbdc277cd0b6255cac9d2437a9cc05f6519 /Makefile.am
parent217db9efe13bb4dee5f29684314a67375bb24315 (diff)
parentdb71bceb4048c0274001ee46ebab2c60f8d11259 (diff)
downloadtor-7fe169a5000d56f081191f4ca073453f2dc3610b.tar.gz
tor-7fe169a5000d56f081191f4ca073453f2dc3610b.zip
Merge branch 'tor-github/pr/879' into maint-0.4.0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b40b2e51bc..d65c08f6bf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -295,8 +295,10 @@ test-full: need-stem-path need-chutney-path check test-network test-stem
test-full-online: need-stem-path need-chutney-path check test-network test-stem-full
+# We can't delete the gcno files, because they are created when tor is compiled
reset-gcov:
- rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda
+ rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda \
+ $(top_builddir)/src/*/*.gcov $(top_builddir)/src/*/*/*.gcov
HTML_COVER_DIR=$(top_builddir)/coverage_html
coverage-html: all