summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-10-11 20:25:41 -0500
committerTaylor Yu <catalyst@torproject.org>2018-10-12 15:55:15 -0500
commit36ba506508ec5406be3d8c6a3b275fba069a7edf (patch)
tree0feb27bd128bb95ecd314912303baf901be23e3c /Makefile.am
parentbfab1dda2b66f42216c117a12eef076fefda481e (diff)
downloadtor-36ba506508ec5406be3d8c6a3b275fba069a7edf.tar.gz
tor-36ba506508ec5406be3d8c6a3b275fba069a7edf.zip
report origin of mystery core file
Report what program produced the mysterious core file that we occasionally see on Travis CI during make distcheck. Closes ticket 28024.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a0f513c75e..e5c1be31b5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -452,6 +452,15 @@ show-distdir-testlog:
else \
cat $(distdir)/_build/$(TEST_SUITE_LOG); fi
+# Similarly, this relies on automake internals to run file on an
+# intermittent core file whose provenance is not known to us. See
+# ticket 26787.
+show-distdir-core:
+ @if test -d "$(distdir)/_build/sub"; then \
+ file $(distdir)/_build/sub/core ; \
+ else \
+ file $(distdir)/_build/core; fi
+
show-libs:
@echo $(TOR_INTERNAL_LIBS)