summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-07-17 15:28:48 +0200
committerNick Mathewson <nickm@torproject.org>2019-07-18 09:28:08 -0400
commitd6a3636cdcb2556e99744dc3685db2010e151291 (patch)
tree2b25f53c67b8f2f8e22491b4b2db4e7ae8faf64f /Makefile.am
parent6303c9aa2647365fa66de2b6ce1af109417b6603 (diff)
downloadtor-d6a3636cdcb2556e99744dc3685db2010e151291.tar.gz
tor-d6a3636cdcb2556e99744dc3685db2010e151291.zip
Add a TOR_DISABLE_PRACTRACKER envvar for use by folks who don't care
Fixes part of bug 30752
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e823f9e103..d6ea72c17a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -369,7 +369,9 @@ endif
check-best-practices:
if USEPYTHON
- $(PYTHON) $(top_srcdir)/scripts/maint/practracker/practracker.py $(top_srcdir)
+ @if test "$$TOR_DISABLE_PRACTRACKER" = ""; then \
+ $(PYTHON) $(top_srcdir)/scripts/maint/practracker/practracker.py $(top_srcdir); \
+ fi
endif
practracker-regen: