summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-08-01 13:45:45 -0400
committerNick Mathewson <nickm@torproject.org>2019-08-01 13:47:05 -0400
commit394528241947800a0ac881b8890e5af387e0e9d7 (patch)
treecde04660c633a0f461148a869bbe9e887d6c58c8 /Makefile.am
parent1d6054f75065214c55d17796cf1587692fbb5cea (diff)
downloadtor-394528241947800a0ac881b8890e5af387e0e9d7.tar.gz
tor-394528241947800a0ac881b8890e5af387e0e9d7.zip
make dist: only include files from practracker dir intentionally.
Previously, we included temporary files and whatnot, which is not good. Fixes bug 31311; bugfix on 0.4.1.1-alpha.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f3de34ceb..10bd4b45c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -165,9 +165,12 @@ EXTRA_DIST+= \
README \
ReleaseNotes \
scripts/maint/checkIncludes.py \
- scripts/maint/checkSpace.pl \
- scripts/maint/practracker
-
+ scripts/maint/checkSpace.pl \
+ scripts/maint/practracker/exceptions.txt \
+ scripts/maint/practracker/metrics.py \
+ scripts/maint/practracker/practracker.py \
+ scripts/maint/practracker/problem.py \
+ scripts/maint/practracker/util.py
## This tells etags how to find mockable function definitions.
AM_ETAGSFLAGS=--regex='{c}/MOCK_IMPL([^,]+,\W*\([a-zA-Z0-9_]+\)\W*,/\1/s'