summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2019-06-24 13:45:05 -0400
committerNick Mathewson <nickm@torproject.org>2019-06-24 13:45:05 -0400
commita87700633c91f98d3cef16bc7e4809a7ab6b4c2c (patch)
tree1795063c0b6b9fe0724bba1ed664f4fc1281d72f /Makefile.am
parentaec359ef6264881545d5ff313071722479ecb0de (diff)
downloadtor-a87700633c91f98d3cef16bc7e4809a7ab6b4c2c.tar.gz
tor-a87700633c91f98d3cef16bc7e4809a7ab6b4c2c.zip
Don't try to shellcheck src/rust/registry
Fixes bug 30963; bug not in any released Tor.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index df30e0b59a..67ef77f876 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -224,7 +224,7 @@ test: all
shellcheck:
# Only use shellcheck if it is present
if command -v shellcheck; then \
- find "$(top_srcdir)" -name "*.sh" -not -path "$(top_srcdir)/src/ext/*" -exec shellcheck {} +; \
+ find "$(top_srcdir)" -name "*.sh" -not -path "$(top_srcdir)/src/ext/*" -not -path "$(top_srcdir)/src/rust/registry/*" -exec shellcheck {} +; \
if [ -d "$(top_srcdir)/scripts/test" ]; then \
shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_srcdir)/scripts/test/coverage; \
fi; \