summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-04-26 15:58:39 -0500
committerTaylor Yu <catalyst@torproject.org>2018-04-26 15:58:39 -0500
commit2edc9cd48457169409841c794832172bc959e63a (patch)
tree1f6ae71dbf3b45996254ba8e767dc968bd908a40 /Makefile.am
parent7c3f87eb4b2c3c4ce3422b3561bee36f3c9956c1 (diff)
parent59821050982a7e1c6906de61b6742546378e569c (diff)
downloadtor-2edc9cd48457169409841c794832172bc959e63a.tar.gz
tor-2edc9cd48457169409841c794832172bc959e63a.zip
Merge branch 'bug25936-031' into bug25936-032
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a126986f3a..4d2d9d222a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -247,3 +247,12 @@ mostlyclean-local:
clean-local:
rm -rf $(top_builddir)/src/rust/target
rm -rf $(top_builddir)/src/rust/.cargo/registry
+
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi