summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGeorge Kadianakis <desnacked@riseup.net>2019-04-05 14:55:22 +0300
committerGeorge Kadianakis <desnacked@riseup.net>2019-04-05 14:55:22 +0300
commit76f1763976948faab07a98048958e86a28a8ef29 (patch)
tree527f62d97b3b9ce309cdff6c1864f519b8f697e5 /Makefile.am
parent3393c8d510a5d62fefbc8c00e4b97d889d6f3143 (diff)
parent7fe169a5000d56f081191f4ca073453f2dc3610b (diff)
downloadtor-76f1763976948faab07a98048958e86a28a8ef29.tar.gz
tor-76f1763976948faab07a98048958e86a28a8ef29.zip
Merge branch 'maint-0.4.0'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 673643cd31..de11696965 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -301,8 +301,10 @@ test-full: need-stem-path need-chutney-path check test-network test-stem
test-full-online: need-stem-path need-chutney-path check test-network test-stem-full
+# We can't delete the gcno files, because they are created when tor is compiled
reset-gcov:
- rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda
+ rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda \
+ $(top_builddir)/src/*/*.gcov $(top_builddir)/src/*/*/*.gcov
HTML_COVER_DIR=$(top_builddir)/coverage_html
coverage-html: all