summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor@torproject.org>2019-04-01 13:49:27 +1000
committerteor <teor@torproject.org>2019-04-01 14:06:52 +1000
commit57e9fe2bbaa66ee907d68cdf7ebcf2111bd71ac9 (patch)
treebbe540595b99bae9a02af15fcf2e706063ccf033 /Makefile.am
parenteb0bd18d6e344c574614d6d53e2f7cead92c3178 (diff)
downloadtor-57e9fe2bbaa66ee907d68cdf7ebcf2111bd71ac9.tar.gz
tor-57e9fe2bbaa66ee907d68cdf7ebcf2111bd71ac9.zip
Makefile: delete all the gcov-related files in reset-gcov
And fix a comment. See: https://gcc.gnu.org/onlinedocs/gcc/Gcov-Data-Files.html#Gcov-Data-Files
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e4be3f26f9..4b1687f921 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -149,7 +149,9 @@ test-full: need-stem-path need-chutney-path check test-network test-stem
test-full-online: need-stem-path need-chutney-path check test-network test-stem-full
reset-gcov:
- rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda
+ rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda \
+ $(top_builddir)/src/*/*.gcno $(top_builddir)/src/*/*/*.gcno \
+ $(top_builddir)/src/*/*.gcov $(top_builddir)/src/*/*/*.gcov
HTML_COVER_DIR=$(top_builddir)/coverage_html
coverage-html: all