summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorrl1987 <rl1987@sdf.lonestar.org>2019-06-09 18:20:36 +0300
committerNick Mathewson <nickm@torproject.org>2019-06-17 08:56:02 -0400
commit19dbd431c52994fc14bf7cb2e1a1a0dc686c2599 (patch)
tree2e7bc12eaa1a2ff41fe73c93bb972182750110ec /Makefile.am
parentecc5feff386890ad34378c70a20cbbdd0d338225 (diff)
downloadtor-19dbd431c52994fc14bf7cb2e1a1a0dc686c2599.tar.gz
tor-19dbd431c52994fc14bf7cb2e1a1a0dc686c2599.zip
Shellcheck all the scripts
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 7a0d40d6a5..df30e0b59a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -224,10 +224,19 @@ test: all
shellcheck:
# Only use shellcheck if it is present
if command -v shellcheck; then \
- find $(top_srcdir)/scripts/ -name "*.sh" -exec shellcheck {} +; \
+ find "$(top_srcdir)" -name "*.sh" -not -path "$(top_srcdir)/src/ext/*" -exec shellcheck {} +; \
if [ -d "$(top_srcdir)/scripts/test" ]; then \
shellcheck $(top_srcdir)/scripts/test/cov-diff $(top_srcdir)/scripts/test/coverage; \
fi; \
+ if [ -e "$(top_srcdir)/contrib/dirauth-tools/nagios-check-tor-authority-cert" ]; then \
+ shellcheck "$(top_srcdir)/contrib/dirauth-tools/nagios-check-tor-authority-cert"; \
+ fi; \
+ if [ -e "$(top_srcdir)/contrib/client-tools/torify" ]; then \
+ shellcheck "$(top_srcdir)/contrib/client-tools/torify"; \
+ fi; \
+ if [ -d "$(top_srcdir)/scripts/git" ]; then \
+ shellcheck $(top_srcdir)/scripts/git/*.git-hook; \
+ fi; \
fi
check-local: check-spaces check-changes check-includes check-best-practices shellcheck