summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-21 11:51:49 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-21 13:08:25 -0400
commit2d20cbf837263898ce45c1e0a0f11b9e1126eeba (patch)
tree3af09a830bb62117ec3ddc9d2ea907f861d289ff /Makefile.am
parentad7776f66d3e914a0842c20f31162c0e11befa34 (diff)
downloadtor-2d20cbf837263898ce45c1e0a0f11b9e1126eeba.tar.gz
tor-2d20cbf837263898ce45c1e0a0f11b9e1126eeba.zip
Extract compression functions into a new library.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 59230ab752..5b229d073d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,7 @@ TOR_CRYPTO_TESTING_LIBS = \
# All static libraries used to link tor.
TOR_INTERNAL_LIBS = \
src/or/libtor-app.a \
+ src/lib/libtor-compress.a \
$(TOR_CRYPTO_LIBS) \
$(TOR_UTIL_LIBS) \
src/common/libor-event.a \
@@ -76,10 +77,9 @@ TOR_INTERNAL_LIBS = \
# and tests)
TOR_INTERNAL_TESTING_LIBS = \
src/or/libtor-app-testing.a \
+ src/lib/libtor-compress-testing.a \
$(TOR_CRYPTO_TESTING_LIBS) \
$(TOR_UTIL_TESTING_LIBS) \
- $(LIBKECCAK_TINY) \
- $(LIBDONNA) \
src/common/libor-event-testing.a \
src/trunnel/libor-trunnel-testing.a \
src/trace/libor-trace.a