summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-09-07 10:51:02 -0400
committerNick Mathewson <nickm@torproject.org>2017-09-07 10:51:02 -0400
commit283be00b0bf515ee80b4b1d809d99a2cd682c46b (patch)
tree2030831cb473293590f9b8745665bad7d11f983d /Makefile.am
parent8421756da3fc3cc116d17fe96b50384c0d79af8b (diff)
downloadtor-283be00b0bf515ee80b4b1d809d99a2cd682c46b.tar.gz
tor-283be00b0bf515ee80b4b1d809d99a2cd682c46b.zip
Add support for running "calltool" on Tor via "make callgraph".
Closes #19307.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f1f64f2106..3982f1e8a4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -224,6 +224,10 @@ check-changes:
update-versions:
$(PERL) $(top_builddir)/scripts/maint/updateVersions.pl
+.PHONY: callgraph
+callgraph:
+ $(top_builddir)/scripts/maint/run_calltool.sh
+
version:
@echo "Tor @VERSION@"
@if test -d "$(top_srcdir)/.git" && test -x "`which git 2>&1;true`"; then \