summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
commit810152b20f6d773172e1f28ab72a1d4b2fda2d82 (patch)
treec6dde49cc0d5204fef9167d8c6d0cfd018463c9b /Makefile.am
parent3d7a705d3a05e9f96d330f5862ebf4fb6e2961c8 (diff)
parent0ea622aa3a678f19759a42e9521a259ef4bcf5a4 (diff)
downloadtor-810152b20f6d773172e1f28ab72a1d4b2fda2d82.tar.gz
tor-810152b20f6d773172e1f28ab72a1d4b2fda2d82.zip
Merge branch 'maint-0.3.4'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 35f9841e61..beefc27d58 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -231,6 +231,7 @@ test-network: need-chutney-path $(TESTING_TOR_BINARY) src/tools/tor-gencert
# because they're incompatible
test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/tor-gencert
mkdir -p $(TEST_NETWORK_ALL_LOG_DIR)
+ rm -f $(TEST_NETWORK_ALL_LOG_DIR)/*.log $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
@flavors="$(TEST_CHUTNEY_FLAVORS)"; \
if ping6 -q -c 1 -o ::1 >/dev/null 2>&1 || ping6 -q -c 1 -W 1 ::1 >/dev/null 2>&1 || ping -6 -c 1 -W 1 ::1 >/dev/null 2>&1; then \
echo "ping6 ::1 or ping ::1 succeeded, running IPv6 flavors: $(TEST_CHUTNEY_FLAVORS_IPV6)."; \
@@ -254,7 +255,7 @@ test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/
$(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_WARNING_FLAGS); \
done; \
echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
- ! grep -q FAIL test_network_log/*.trs
+ ! grep -q FAIL $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
need-stem-path:
@if test ! -d "$$STEM_SOURCE_DIR"; then \