summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
committerNick Mathewson <nickm@torproject.org>2018-08-29 11:17:31 -0400
commit0ea622aa3a678f19759a42e9521a259ef4bcf5a4 (patch)
tree7c95c2e96cf63f42a6d407850c473c56940baaf7 /Makefile.am
parent0483f7f64c80fe18c922415ae6062149a2ebb9f7 (diff)
parenta28c14aad547fd1b254bdbf2acc1ff2b67551a96 (diff)
downloadtor-0ea622aa3a678f19759a42e9521a259ef4bcf5a4.tar.gz
tor-0ea622aa3a678f19759a42e9521a259ef4bcf5a4.zip
Merge branch 'maint-0.3.3' into maint-0.3.4
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 552b75a35f..c58140ae74 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -127,6 +127,7 @@ test-network: need-chutney-path $(TESTING_TOR_BINARY) src/tools/tor-gencert
# because they're incompatible
test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/tor-gencert
mkdir -p $(TEST_NETWORK_ALL_LOG_DIR)
+ rm -f $(TEST_NETWORK_ALL_LOG_DIR)/*.log $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
@flavors="$(TEST_CHUTNEY_FLAVORS)"; \
if ping6 -q -c 1 -o ::1 >/dev/null 2>&1 || ping6 -q -c 1 -W 1 ::1 >/dev/null 2>&1 || ping -6 -c 1 -W 1 ::1 >/dev/null 2>&1; then \
echo "ping6 ::1 or ping ::1 succeeded, running IPv6 flavors: $(TEST_CHUTNEY_FLAVORS_IPV6)."; \
@@ -150,7 +151,7 @@ test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/
$(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_WARNING_FLAGS); \
done; \
echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
- ! grep -q FAIL test_network_log/*.trs
+ ! grep -q FAIL $(TEST_NETWORK_ALL_LOG_DIR)/*.trs
need-stem-path:
@if test ! -d "$$STEM_SOURCE_DIR"; then \