summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTies Stuij <ties@stuij.se>2017-08-10 01:08:41 -0700
committerNick Mathewson <nickm@torproject.org>2017-08-21 15:08:24 -0400
commit2e99f839e97e2b5b1e99abdb9a8673380c87ae18 (patch)
tree41cce07bc13c706c4e94d0332b82fb702cef24f5 /Makefile.am
parent8f8a061b0c4724adebb4af1d5ac3edb7381269d5 (diff)
downloadtor-2e99f839e97e2b5b1e99abdb9a8673380c87ae18.tar.gz
tor-2e99f839e97e2b5b1e99abdb9a8673380c87ae18.zip
22839: Build tor with rust enabled on win
- make tor_util static library name configurable - fix Rust libary dependency order for Windows
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79d2e78521..f1f64f2106 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,7 +26,7 @@ TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
if USE_RUST
-rust_ldadd=$(top_builddir)/src/rust/target/release/libtor_util.a
+rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_UTIL_STATIC_NAME@
else
rust_ldadd=
endif