summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChelsea Holland Komlo <me@chelseakomlo.com>2017-10-12 17:29:51 -0400
committerNick Mathewson <nickm@torproject.org>2017-10-27 10:02:08 -0400
commit0c4d535972bcf14fec0b65c82359db28b0cc0091 (patch)
treef7ab90fcf661b29bc1e80cfa16c21832d8eae3db /Makefile.am
parentbe583a34a3815c2c10e86094ab0610e4b7f9c869 (diff)
downloadtor-0c4d535972bcf14fec0b65c82359db28b0cc0091.tar.gz
tor-0c4d535972bcf14fec0b65c82359db28b0cc0091.zip
refactor build infrastructure for single rust binary
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 27ee33e1e9..137fb1edcb 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,7 @@ TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
if USE_RUST
-rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_UTIL_STATIC_NAME@
-rust_ldadd+=$(top_builddir)/src/rust/target/release/@TOR_RUST_PROTOVER_STATIC_NAME@
+rust_ldadd=$(top_builddir)/src/rust/target/release/@TOR_RUST_STATIC_NAME@
else
rust_ldadd=
endif