summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-10-03 13:58:09 -0400
committerNick Mathewson <nickm@torproject.org>2016-10-03 13:58:09 -0400
commita49fb1e2e5ebb03d7d115b4a4eaa1c17c160f1a8 (patch)
tree58758161045ace6ae854c934192e922bebfa666a /Makefile.am
parent3b2f012e28f73267a894c5e3b468c65d8e093b15 (diff)
downloadtor-a49fb1e2e5ebb03d7d115b4a4eaa1c17c160f1a8.tar.gz
tor-a49fb1e2e5ebb03d7d115b4a4eaa1c17c160f1a8.zip
Teach 'make tags' about MOCK_IMPL.
Patch from nherring; closes ticket 16869
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c160af9732..f400728bac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -36,6 +36,9 @@ EXTRA_DIST+= \
README \
ReleaseNotes
+## This tells etags how to find mockable function definitions.
+AM_ETAGSFLAGS=--regex='{c}/MOCK_IMPL([^,]+,\W*\([a-zA-Z0-9_]+\)\W*,/\1/s'
+
if COVERAGE_ENABLED
TEST_CFLAGS=-fno-inline -fprofile-arcs -ftest-coverage
if DISABLE_ASSERTS_IN_UNIT_TESTS