summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2015-07-01 11:08:33 +0200
committerNick Mathewson <nickm@torproject.org>2015-07-02 09:51:28 -0400
commit65a1e27bc42a1cdbb4a920597b3424f7fe065d9c (patch)
tree44ea52408b8e50c7787c04ec64b9d49ab9291462 /Makefile.am
parent877354a9af4bbc6b2cdb15493c1fcc897eff4899 (diff)
downloadtor-65a1e27bc42a1cdbb4a920597b3424f7fe065d9c.tar.gz
tor-65a1e27bc42a1cdbb4a920597b3424f7fe065d9c.zip
Use the configured Python executable to run test-stem-full.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 316086c1e1..87a5d8adcc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -84,7 +84,7 @@ test-stem: $(TESTING_TOR_BINARY)
test-stem-full: $(TESTING_TOR_BINARY)
@if test -d "$$STEM_SOURCE_DIR"; then \
- "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v; \
+ $(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v; \
else \
echo '$$STEM_SOURCE_DIR was not set.'; echo; \
echo "To run these tests, git clone https://git.torproject.org/stem.git/ ; export STEM_SOURCE_DIR=\`pwd\`/stem"; \