summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor (Tim Wilson-Brown) <teor2345@gmail.com>2015-08-27 10:31:35 +1000
committerteor (Tim Wilson-Brown) <teor2345@gmail.com>2015-08-27 10:31:35 +1000
commitd9948dfc9d2b44de66e5a85a486c65a7e2781933 (patch)
tree1d88cde0d69d8cffc3712f10cd079ee5abbbd516 /Makefile.am
parentb531fc7d9a8f75969b0446578ee4afcb109bae3d (diff)
downloadtor-d9948dfc9d2b44de66e5a85a486c65a7e2781933.tar.gz
tor-d9948dfc9d2b44de66e5a85a486c65a7e2781933.zip
Autodetect CHUTNEY_PATH if chutney is next to tor
If the chutney and tor sources are side-by-side in the same parent directory, autodetect the chutney path. Closes ticket 16903. Patch by "teor".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 9b68d2752b..b5e71aad1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -73,9 +73,14 @@ test: all
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \
- echo '$$CHUTNEY_PATH was not set.'; echo; \
- echo "To run these tests, git clone https://git.torproject.org/chutney.git ; export CHUTNEY_PATH=\`pwd\`/chutney"; \
- exit 1; \
+ echo '$$CHUTNEY_PATH was not set.'; \
+ if test -d $(top_srcdir)/../chutney -a -x $(top_srcdir)/../chutney/chutney; then \
+ echo "Assuming test-network.sh will find" $(top_srcdir)/../chutney; \
+ else \
+ echo; \
+ echo "To run these tests, git clone https://git.torproject.org/chutney.git ; export CHUTNEY_PATH=\`pwd\`/chutney"; \
+ exit 1; \
+ fi \
fi
# Note that test-network requires a copy of Chutney in $CHUTNEY_PATH.