summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-01-05 11:52:36 -0500
committerNick Mathewson <nickm@torproject.org>2015-01-06 09:03:44 -0500
commitd74f0cff92322174e19c5cbd98462bd25e14fc3c (patch)
treeef7d504009671a841dc000c5f607fbcfb1751587 /Makefile.am
parent276700131a14697aa84d95a867782bbfd612277f (diff)
downloadtor-d74f0cff92322174e19c5cbd98462bd25e14fc3c.tar.gz
tor-d74f0cff92322174e19c5cbd98462bd25e14fc3c.zip
make "make test-stem" run stem tests on tor
Closes ticket 14107.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3de7f7a827..f6a1bcf520 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -70,6 +70,15 @@ test: all
test-network: all
./src/test/test-network.sh
+test-stem: $(TESTING_TOR_BINARY)
+ @if test -d "$$STEM_SOURCE_DIR"; then \
+ "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL; \
+ else \
+ echo '$$STEM_SOURCE_DIR was not set.'; echo; \
+ echo "To run these tests, git clone https://git.torproject.org/stem.git/ ; export STEM_SOURCE_DIR=\`pwd\`/stem"; \
+ fi
+
+
reset-gcov:
rm -f src/*/*.gcda