summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2015-08-03 13:03:58 -0400
committerNick Mathewson <nickm@torproject.org>2015-08-03 13:03:58 -0400
commit6de49f4d9a9c0f0788e44e7199b935e175fb0ad4 (patch)
tree7c8f76dfcb07f18899c113289201f2466f73fb01 /Makefile.am
parent347fe449fe818f97e0f3ba29dd0a08ff6d39081e (diff)
downloadtor-6de49f4d9a9c0f0788e44e7199b935e175fb0ad4.tar.gz
tor-6de49f4d9a9c0f0788e44e7199b935e175fb0ad4.zip
Improved targets for "run all the tests, no, all of them."
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am32
1 files changed, 20 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index 87a5d8adcc..784ff48dcd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -69,26 +69,34 @@ doxygen:
test: all
$(top_builddir)/src/test/test
+need-chutney-path:
+ @if test ! -d "$$CHUTNEY_PATH"; then \
+ echo '$$CHUTNEY_PATH was not set.'; echo; \
+ echo "To run these tests, git clone https://git.torproject.org/chutney.git ; export CHUTNEY_PATH=\`pwd\`/chutney"; \
+ exit 1; \
+ fi
+
# Note that test-network requires a copy of Chutney in $CHUTNEY_PATH.
# Chutney can be cloned from https://git.torproject.org/chutney.git .
-test-network: all
+test-network: need-chutney-path all
$(top_srcdir)/src/test/test-network.sh
-test-stem: $(TESTING_TOR_BINARY)
- @if test -d "$$STEM_SOURCE_DIR"; then \
- $(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL; \
- else \
+need-stem-path:
+ @if test ! -d "$$STEM_SOURCE_DIR"; then \
echo '$$STEM_SOURCE_DIR was not set.'; echo; \
echo "To run these tests, git clone https://git.torproject.org/stem.git/ ; export STEM_SOURCE_DIR=\`pwd\`/stem"; \
+ exit 1; \
fi
-test-stem-full: $(TESTING_TOR_BINARY)
- @if test -d "$$STEM_SOURCE_DIR"; then \
- $(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v; \
- else \
- echo '$$STEM_SOURCE_DIR was not set.'; echo; \
- echo "To run these tests, git clone https://git.torproject.org/stem.git/ ; export STEM_SOURCE_DIR=\`pwd\`/stem"; \
- fi
+test-stem: need-stem-path $(TESTING_TOR_BINARY)
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL;
+
+test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
+ @$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v;
+
+test-full: need-stem-path need-chutney-path check test-network test-stem
+
+test-full-online: need-stem-path need-chutney-path check test-network test-stem-full
reset-gcov:
rm -f $(top_builddir)/src/*/*.gcda $(top_builddir)/src/*/*/*.gcda