summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2015-03-12 09:28:41 +0100
committerNick Mathewson <nickm@torproject.org>2015-03-14 13:00:06 -0400
commite85ba7459e6270b5ec1186a18e87a60c13153344 (patch)
tree6b90d3e384f284234bbddd706d3e4d019b07d610 /Makefile.am
parentce9bd4e04ce54b6b001c096f7caab2d0beaef941 (diff)
downloadtor-e85ba7459e6270b5ec1186a18e87a60c13153344.tar.gz
tor-e85ba7459e6270b5ec1186a18e87a60c13153344.zip
Revive updateVersions.pl with `make update-versions`.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4527dd1244..1c2d2c1909 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,6 +122,10 @@ check-changes:
$(PYTHON) $(top_srcdir)/scripts/maint/lintChanges.py $(top_srcdir)/changes/*; \
fi
+.PHONY: update-versions
+update-versions:
+ $(PERL) $(top_builddir)/scripts/maint/updateVersions.pl
+
version:
@echo "Tor @VERSION@"
@if test -d "$(top_srcdir)/.git" && test -x "`which git 2>&1;true`"; then \