summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2006-09-24 21:45:02 +0000
committerNick Mathewson <nickm@torproject.org>2006-09-24 21:45:02 +0000
commitb1ad605780cb026f44040c73deebff525c44c66e (patch)
treeda9bfc572a7fd059807888ad335b7c08cf7a265e /Makefile.am
parentbda137501e987926f5dbdb9fe7287201f631ccde (diff)
downloadtor-b1ad605780cb026f44040c73deebff525c44c66e.tar.gz
tor-b1ad605780cb026f44040c73deebff525c44c66e.zip
Build correctly for use on OS X platforms with case-sensitive filesystems
svn:r8487
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6179291fd1..e6c491e424 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,6 +46,9 @@ dist-osx:
if [ "x$(sysconfdir)" != 'x/Library' ]; then \
echo "Configure with --sysconfdir=/Library, please"; \
exit 1; \
+ fi; \
+ if [ "x$(CONFDIR)" != 'x/Library/Tor' ]; then \
+ echo "Configure with CONFDIR=/Library/Tor, please"; \
fi
$(MAKE) all
VERSION=$(VERSION) sh ./contrib/osx/package.sh