summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2005-01-05 02:46:25 +0000
committerNick Mathewson <nickm@torproject.org>2005-01-05 02:46:25 +0000
commit20142a2508b6fb486a7df4b61afae4522fd32571 (patch)
treeb0dc496d6fb31ea6f20489a8bf3aba8bb22d40e9 /Makefile.am
parent041edf87548688b67477b9216268d18501160a4e (diff)
downloadtor-20142a2508b6fb486a7df4b61afae4522fd32571.tar.gz
tor-20142a2508b6fb486a7df4b61afae4522fd32571.zip
Forward-port OSX packaging stuff from maint branch
svn:r3299
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1e1013e6dc..068c15c0db 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,22 @@ dist-rpm: dist
mv $$RPM_BUILD_DIR/RPMS/*/* .; \
rm -rf $$RPM_BUILD_DIR
+dist-osx:
+ @if [ "x$(prefix)" != 'x/Library/Tor' ]; then \
+ echo "Configure with --prefix=/Library/Tor, please"; \
+ exit 1; \
+ fi; \
+ if [ "x$(bindir)" != 'x/Library/Tor' ]; then \
+ echo "Configure with --bindir=/Library/Tor, please"; \
+ exit 1; \
+ fi; \
+ if [ "x$(sysconfdir)" != 'x/Library' ]; then \
+ echo "Configure with --sysconfdir=/Library, please"; \
+ exit 1; \
+ fi
+ $(MAKE) all
+ VERSION=$(VERSION) sh ./contrib/osx/package.sh
+
doxygen:
doxygen && cd doc/doxygen/latex && make