aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-06-22 11:40:20 -0400
committerNick Mathewson <nickm@torproject.org>2018-06-22 11:40:20 -0400
commit79f73ab330c0e643ba1ec2eb0633f0f80525a083 (patch)
treea4e923238c46a51efdd946bdcc890313d3336db4 /Makefile.am
parent90a09df5ba7b3e55ea388a4cc9b92161442bb380 (diff)
downloadtor-79f73ab330c0e643ba1ec2eb0633f0f80525a083.tar.gz
tor-79f73ab330c0e643ba1ec2eb0633f0f80525a083.zip
Finally extract the log library and make it build.
This patch: - introduces an fdio module for low-level fd functions that don't need to log. - moves the responsibility for opening files outside of torlog.c, so it won't need to call tor_open_cloexec.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b6200c6a27..61451ed264 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,6 +42,7 @@ TOR_UTIL_LIBS = \
src/common/libor.a \
src/lib/libtor-log.a \
src/lib/libtor-lock.a \
+ src/lib/libtor-fdio.a \
src/lib/libtor-container.a \
src/lib/libtor-string.a \
src/lib/libtor-malloc.a \
@@ -56,6 +57,7 @@ TOR_UTIL_TESTING_LIBS = \
src/common/libor-testing.a \
src/lib/libtor-log-testing.a \
src/lib/libtor-lock-testing.a \
+ src/lib/libtor-fdio-testing.a \
src/lib/libtor-container-testing.a \
src/lib/libtor-string-testing.a \
src/lib/libtor-malloc-testing.a \