aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-04-26 14:22:52 -0500
committerTaylor Yu <catalyst@torproject.org>2018-04-26 15:35:47 -0500
commit31865b50295753706ff3a9eb598e080bb2167639 (patch)
treec3cd63f8c2d8ed64031048a2270aa57792e48463 /Makefile.am
parent34e7dca9c9e902a58fe8942cef666f1d99d06030 (diff)
downloadtor-31865b50295753706ff3a9eb598e080bb2167639.tar.gz
tor-31865b50295753706ff3a9eb598e080bb2167639.zip
Show test-suite.log for distcheck on Travis CI
When Travis CI runs make distcheck, test-suite.log doesn't exist in the expected place. Add a new make target to show this file and use it when DISTCHECK=yes in .travis.yml. Fixes bug 25814; bug not in any released Tor.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index f400728bac..f06d0e3734 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -216,3 +216,12 @@ mostlyclean-local:
rm -rf $(HTML_COVER_DIR)
rm -rf $(top_builddir)/doc/doxygen
rm -rf $(TEST_NETWORK_ALL_LOG_DIR)
+
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi