aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSebastian Hahn <sebastian@torproject.org>2017-04-29 08:51:51 +0200
committerSebastian Hahn <sebastian@torproject.org>2017-04-29 08:55:57 +0200
commit915fa39d0f927712f7a468c0a2f4497aef0a3b0f (patch)
tree9e8d805a4b9bcbd30138ff79560708099469412d /Makefile.am
parentb8f7488e94f2cb83bdf83228781a11233d9f0a46 (diff)
downloadtor-915fa39d0f927712f7a468c0a2f4497aef0a3b0f.tar.gz
tor-915fa39d0f927712f7a468c0a2f4497aef0a3b0f.zip
Add --enable-rust configure switch
Introduce a way to optionally enable Rust integration for our builds. No actual Rust code is added yet and specifying the flag has no effect other than failing the build if rustc and cargo are unavailable.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index be1dc7f7ef..b8aa049da1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -25,6 +25,12 @@ else
TESTING_TOR_BINARY=$(top_builddir)/src/or/tor$(EXEEXT)
endif
+if USE_RUST
+rust_ldadd=
+else
+rust_ldadd=
+endif
+
include src/include.am
include doc/include.am
include contrib/include.am