aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorteor <teor2345@gmail.com>2017-02-28 01:46:16 +1100
committerteor <teor2345@gmail.com>2017-02-28 02:01:37 +1100
commitfb32c522320430f0fb419e1f05530850a5a90d2f (patch)
tree93fd91ee715da2055a4a240b91b5c626dc2aac42 /Makefile.am
parent39a4c5624bdb327166b2bf784c11c4cfab56895c (diff)
downloadtor-fb32c522320430f0fb419e1f05530850a5a90d2f.tar.gz
tor-fb32c522320430f0fb419e1f05530850a5a90d2f.zip
Log tor warnings during 'make test-network-all'
Requires the chutney changes from 21572. (Otherwise, asks users to upgrade their chutney.) Implements 21570.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 631b44e7f5..880420b287 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -54,6 +54,7 @@ TEST_CFLAGS=
TEST_CPPFLAGS=-DTOR_UNIT_TESTS
TEST_NETWORK_FLAGS=--hs-multi-client 1
endif
+TEST_NETWORK_WARNING_FLAGS=--quiet --only-warnings
if LIBFUZZER_ENABLED
TEST_CFLAGS += -fsanitize-coverage=trace-pc-guard,trace-cmp,trace-div
@@ -135,6 +136,10 @@ test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/
done; \
for f in $$flavors; do \
$(SHELL) $(top_srcdir)/test-driver --test-name $$f --log-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.log --trs-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.trs $(TEST_NETWORK_ALL_DRIVER_FLAGS) $(top_srcdir)/src/test/test-network.sh --flavor $$f $(TEST_NETWORK_FLAGS); \
+ $(top_srcdir)/src/test/test-network.sh $(TEST_NETWORK_WARNING_FLAGS); \
+ if test $$? -eq 2 ; then \
+ echo "Please update your chutney using 'git pull' to see tor warnings here."; \
+ fi; \
done; \
echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
! grep -q FAIL test_network_log/*.trs