aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2018-05-03 13:38:54 -0400
committerNick Mathewson <nickm@torproject.org>2018-05-03 13:38:54 -0400
commitbe5b4415c2dce243a6249e6ca14b65423c9b0746 (patch)
tree60c60f213aac9743117795607923b25550392973 /Makefile.am
parent246765342e681ae6f8c35709f9acd9a78d7048d2 (diff)
parent6361a250f08421aa1e6db1093aaa488ee24ce77d (diff)
downloadtor-be5b4415c2dce243a6249e6ca14b65423c9b0746.tar.gz
tor-be5b4415c2dce243a6249e6ca14b65423c9b0746.zip
Merge branch 'maint-0.3.1' into maint-0.3.2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a126986f3a..4d2d9d222a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -247,3 +247,12 @@ mostlyclean-local:
clean-local:
rm -rf $(top_builddir)/src/rust/target
rm -rf $(top_builddir)/src/rust/.cargo/registry
+
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi