aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTaylor Yu <catalyst@torproject.org>2018-04-26 15:46:57 -0500
committerTaylor Yu <catalyst@torproject.org>2018-04-26 15:46:57 -0500
commit59821050982a7e1c6906de61b6742546378e569c (patch)
tree6bc882bcd9530550eca4567c86878cbc2490956e /Makefile.am
parentbb35405d2ad01dbc8cf59ed275c41bd7d6098ae8 (diff)
parent31865b50295753706ff3a9eb598e080bb2167639 (diff)
downloadtor-59821050982a7e1c6906de61b6742546378e569c.tar.gz
tor-59821050982a7e1c6906de61b6742546378e569c.zip
Merge branch 'bug25936-029' into bug25936-031
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 79d2e78521..1a6d8e7d12 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -240,3 +240,12 @@ mostlyclean-local:
clean-local:
rm -rf $(top_builddir)/src/rust/target
rm -rf $(top_builddir)/src/rust/.cargo/registry
+
+# This relies on some internal details of how automake implements
+# distcheck. We check two directories because automake-1.15 changed
+# from $(distdir)/_build to $(distdir)/_build/sub.
+show-distdir-testlog:
+ @if test -d "$(distdir)/_build/sub"; then \
+ cat $(distdir)/_build/sub/$(TEST_SUITE_LOG); \
+ else \
+ cat $(distdir)/_build/$(TEST_SUITE_LOG); fi