aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2017-09-19 10:10:38 -0400
committerNick Mathewson <nickm@torproject.org>2017-09-21 16:25:24 -0400
commit3c04c8317fc98aa64f9be18042a7255842e951c0 (patch)
treee1ed1ef23ca86c67b3fa233646c4e0e17fe1aaf7 /Makefile.am
parentf395f41868514a0e418c95f3203d59f3aca6fa47 (diff)
downloadtor-3c04c8317fc98aa64f9be18042a7255842e951c0.tar.gz
tor-3c04c8317fc98aa64f9be18042a7255842e951c0.zip
Make check-spaces part of the standard "make check" process
To do this, we had to make sure it passes when the changes directory is empty. I also tried to improve the quality of the output, and fix some false-positive cases. Let's see how this goes! Closes ticket 23564.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3982f1e8a4..7c454f79c6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,7 +96,7 @@ doxygen:
test: all
$(top_builddir)/src/test/test
-check-local: check-spaces
+check-local: check-spaces check-changes
need-chutney-path:
@if test ! -d "$$CHUTNEY_PATH"; then \
@@ -217,7 +217,7 @@ check-logs:
.PHONY: check-changes
check-changes:
@if test -d "$(top_srcdir)/changes"; then \
- $(PYTHON) $(top_srcdir)/scripts/maint/lintChanges.py $(top_srcdir)/changes/*; \
+ $(PYTHON) $(top_srcdir)/scripts/maint/lintChanges.py $(top_srcdir)/changes; \
fi
.PHONY: update-versions