aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2016-06-16 12:16:57 +0000
committerNick Mathewson <nickm@torproject.org>2016-07-08 10:19:18 -0400
commit3ac434104af0a40e75bfb5116046eae1cd51f6d3 (patch)
tree98a6c9dd77bd9823f932521b3816507c69cf16f5 /Makefile.am
parent466259eb5083cbab203b56c55a4da2e6515d8767 (diff)
downloadtor-3ac434104af0a40e75bfb5116046eae1cd51f6d3.tar.gz
tor-3ac434104af0a40e75bfb5116046eae1cd51f6d3.zip
Fix test-network-all target in out-of-tree builds
The test-network-all target assumes the test-driver script lives in the current working directory. This assumption breaks out-of-tree builds because it actually lives in the source directory. Automake 1.12 introduces `LOG_DRIVER` which defines the location of the test driver script. Because Tor still supports Automake 1.11 we use the default value of this variable directly. The default value uses the configured shell for calling the test driver script and explicitly prefixes the source directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 4f666e30ec..e45856c367 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -122,7 +122,7 @@ test-network-all: need-chutney-path test-driver $(TESTING_TOR_BINARY) src/tools/
echo "SKIP: $$f"; \
done; \
for f in $$flavors; do \
- ./test-driver --test-name $$f --log-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.log --trs-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.trs $(TEST_NETWORK_ALL_DRIVER_FLAGS) $(top_srcdir)/src/test/test-network.sh --flavor $$f $(TEST_NETWORK_FLAGS); \
+ $(SHELL) $(top_srcdir)/test-driver --test-name $$f --log-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.log --trs-file $(TEST_NETWORK_ALL_LOG_DIR)/$$f.trs $(TEST_NETWORK_ALL_DRIVER_FLAGS) $(top_srcdir)/src/test/test-network.sh --flavor $$f $(TEST_NETWORK_FLAGS); \
done; \
echo "Log and result files are available in $(TEST_NETWORK_ALL_LOG_DIR)."; \
! grep -q FAIL test_network_log/*.trs