aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorcypherpunks <cypherpunks@torproject.org>2015-09-25 16:39:11 +0200
committerNick Mathewson <nickm@torproject.org>2015-12-14 13:11:20 -0500
commit670affa792e7613f6e6b5d960805418359ac0ec7 (patch)
treec71b7044315e26b16537a22a1f1b2aa1262b6356 /Makefile.am
parentaa40f289624c74bcd43b91f15cc43e7f17e9df25 (diff)
downloadtor-670affa792e7613f6e6b5d960805418359ac0ec7.tar.gz
tor-670affa792e7613f6e6b5d960805418359ac0ec7.zip
Only setup environment variables for tests
Using the AM_TESTS_ENVIRONMENT variable ensures the environment variables are only set during test execution and not during the compilation phase.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index c226113cc8..beea69d95e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,6 +21,13 @@ bin_SCRIPTS=
AM_CPPFLAGS=
AM_CFLAGS = @TOR_SYSTEMD_CFLAGS@
SHELL = @SHELL@
+
+if COVERAGE_ENABLED
+TESTING_TOR_BINARY="$(top_builddir)/src/or/tor-cov"
+else
+TESTING_TOR_BINARY="$(top_builddir)/src/or/tor"
+endif
+
include src/include.am
include doc/include.am
include contrib/include.am