aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNick Mathewson <nickm@torproject.org>2016-02-24 15:49:55 -0500
committerNick Mathewson <nickm@torproject.org>2016-02-24 15:49:55 -0500
commit040ec4d0347235da4fd5696b3eb063e609047024 (patch)
tree8868442f9dd3733d05c03a995a39b9b254518621 /Makefile.am
parentf2e23d5ad637d0337057d6f5c51644ed23c8d369 (diff)
downloadtor-040ec4d0347235da4fd5696b3eb063e609047024.tar.gz
tor-040ec4d0347235da4fd5696b3eb063e609047024.zip
Repare dependency in "make test-stem".
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fe6f64bb66..bae506ab0f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -139,10 +139,10 @@ need-stem-path:
exit 1; \
fi
-test-stem: need-stem-path $(TESTING_TOR_BINARY)
+test-stem: need-stem-path all
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL;
-test-stem-full: need-stem-path $(TESTING_TOR_BINARY)
+test-stem-full: need-stem-path all
@$(PYTHON) "$$STEM_SOURCE_DIR"/run_tests.py --tor $(TESTING_TOR_BINARY) --all --log notice --target RUN_ALL,ONLINE -v;
test-full: need-stem-path need-chutney-path check test-network test-stem